Emulador Android -> Audio Muere

Escuchar música mientras trabajas es una cosa necesaria para concentrarse mejor… al menos para mi.

Ahora último estoy haciendo una app en Android de un sistema que ya tenemos (es un más un cliente para un módulo, algo así) y cada vez que lanzaba el emulador, no escuchaba nada de audio …

Tengo unos Phillips SHB4000 (Bluetooth) y pensé que el problema podría ser que intentaban parearse con el emulador … pero no.

En una de esas era el emulador que se “adueñaba” del audio del PC así que lancé el emulador con -no-audio, pero el problema seguía. Intenté con unos audífonos “alámbricos” y el audio si funcionaba… Le di mil vueltas hasta que me rendí y me fui a google: encontré la solución.

Resulta que si los audífonos tienen micrófono (independiente de la marca) el S.O. (da lo mismo cuál) activa el micrófono y por eso no se escucha nada …

Solución: cambiar el dispositivo de grabación por el micrófono interno.

Captura

Y eso fue todo … En Mac o los Linux debería ser el mismo arreglo.

Anuncios

Acerca de MaritoCares

Ingeniero Informático. Con tendencias a la programación en [C#, VB].NET, Java(Web principalmente...), PHP, JavaScript, algo mínimo de [ruby, python], y el clásico C.
Esta entrada fue publicada en Android, Aplicación, Tips, Windows. Guarda el enlace permanente.

Responder

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión / Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión / Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión / Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión / Cambiar )

Conectando a %s